RSS Feed

Posts Tagged ‘niefun’

  1. Everybody lies + trust noone, szczególnie na przejmowanych sieciach

    Marzec 10, 2011 by 0verlord

    Uzupełnienie historyjki z poprzedniego posta.

    Wchodzimy do tktelekomowni, technik pokazuje dwa serwery. Jeden to hosting („to ten na dole”) drugi to router („ten obok szafy na półce”, tak, kiedyś zrobię zdjęcie :P, pewnie im kabli nie starczyło).

    Oglądam, router ma dwa interfejsy i kabelki, hosting ma jeden. Init=/bin/bash załatwił problem, host wstał, patrzę w ipki, nie ma tego, na który się logowałem wcześniej. Dopisałem, rebutnąłem, a że akcja była szybka, bo kolejarze o 16 kończą pracę, poszliśmy.

    Loguję się wieczorkiem, a ten host nie przypomina tego, z którego robiłem backup. Podniosłem apacza, bo nie wstawał, odzyskałem pocztę, ale dalej nie działał LMS. Po krótkiej chwili popatrzyłem do backupu, który na szczęście zrobiłem, zanim host się zapętlił i zmarł.
    To zdecydowanie był inny host. Z konfiguracji wynikało, że tamten miał tylko jeden interfejs, więc nie był routerem. Czyli hosting stał na routerze, a LMS na serwerze. Padł LMS a nie serwer, a że hosting też był routerem, net ludziom działał. Tylko zaktualizować się nie da, bo LMS nie działa. A jeszcze na dokładkę dowiedziałem się, że serwer LMSa ma 1 GB dysku bo stał na nim LMS. Tak, z mysqlem reającym po nim na maksa, pozwalającym na podłączenie się demonom itp.

    Tak, następnym razem nikomu nie uwierzę, i sprawdzę sam co za hosty mam przejmować.

    Trzyosobowa komisja w składzie ja, ja i ja przyznaje temu serweru i jego adminowi betonowa kostkę jako symbol ogólnego braku kumacji.


  2. Dlaczego należy rebootować każdy przejmowany serwer

    Marzec 9, 2011 by 0verlord

    Śmieszno-smutne.

    Generalnie przejmowałem routery jakiejś firemki. Pan były właściciel przestał chcieć współpracować, haseł nie podał, LMSa popsuł. No to pojechaliśmy uratować świat.
    init=/bin/bash do gruba jak zwykle załatwił sprawę, ale do drugiego routera nie dojechałem, bo nagle hasło się „odnalazło”, w głowie serwisanta. Przypomniał sobie nagle.

    Skąd serwisant znał hasło do roota na routerze, nie wiem. Zalogowałem się, wyłączyłem filtrowanie portu na ssh i wróciłem do domu. Wieczorem klikałem różne graty, między innymi firewalla, pingera do LMSa itp. Po którymśtam przeładowaniu regułek firewalla, host się zapętlił i padł. Ostatni load jaki zauważyłem na ostatniej zalogowanej konsoli, to 22, więc niby źle nie było, ale pacjent zszedł.

    Zaordynowałem Finger Of God. Rano palec zadziałał, natomiast host już nie wstał. Próba reanimacji przez serwisanta nie dała rady, host rzucał kernel panicami. Załadowałem niezbędne graty i pojechałem naprawiać.

    Na miejscu okazało się, że wszystko w sumie działa, tylko host wstał z zupełnie innym zestawem adresów IP niż w momencie, w którym klikałem filtry. Cóż było robić, naprawiłem i wróciłem do domu.

    Czas poszukać KVMa jakiegoś sensownego i przygotować serwisantowi skrypty diagnostyczne.


  3. Jak to Pan Technik przepiął kabel od konsoli Panu Adminowi

    Styczeń 28, 2011 by 0verlord

    Śmieszno-smutne.

    Generalnie mam w szafie dwa hosty, jeden nad drugim, a nad nimi jeszcze switch. Switcha miałem do tej pory przypiętego serialem do routera, bo tam to miało więcej sensu.
    Nagle zniknęło zarządzanie po serialu. No to poprosiłem Kogo Trzeba, żeby mi tenże kabelek podopychał (chociaż dałbym głowę, że zakręcałem śrubki właśnie po to, żeby nikt nie musiał nic dopychać).

    – zrobione, tak, dopchnąłem kable, tak super ekstra i działa na pewno. Tak, na pewno jest do właściwego serwera. Do tego Della. Tak, do tego czarnego.

    Gwoli wyjaśnienia – są dwa, jeden jest srebrny z przodu, a drugi czarny. Z tyłu w sumie nie pamiętam jakie są.
    Klikam minicoma – niema. Podsumowałem chińską technologię wiązanką kwiatów polskich. Ale coś mnie tknęło i popatrzyłem na hosta obok. Tak, zarządzanie jest i owszem, ale w tym drugim Dellu. W tym srebrnym.