RSS Feed

‘hardware’ Category

  1. Dla potomnych, ku pamięci, Windows 95.

    Grudzień 17, 2013 by 0verlord

    Czasami grzebiemy też w takich rzeczach. Parametry powalają, łza się w oku kręci a przedszkolaki mają szybsze zegarki. Jeżeli pamiętasz te czasy i te maszyny, to rispekt men!

    zdjęcie
    zdjęcie
    zdjęcie


  2. Mikrotik i konfiguracja wifi dla gości – część 1: rb w trybie routera

    Grudzień 12, 2013 by 0verlord

    Czasem przychodzą do nas znajomi/krewni/rodzina i chcą się na chwilę podpiąć do naszej sieci bezprzewodowej. W większości domowych zastosowań nie ma z tym problemów – podajemy hasło i już. Tym przypadkiem nie będziemy się zajmować 😉 W końcu mamy urządzenie sieciowe, które może wiele – Mikrotika.

    Będziemy się zajmować rozwiązaniem firmowym albo rozwiązaniem dla ludzi, którzy nie chcą wpuszczać nikogo na stałe do swojej sieci domowej.

    Jednym z takich przypadków jest np. sala konferencyjna, do której przychodzą ludzie spoza firmy, coś tam prezentują, potrzebują się dostać do swoich sieci czy do swojej poczty.
    Ale nie powinni, i nie mogą mieć dostępu do reszty firmowego lanu.

    Jak zapewne wiedzą posiadacze urządzeń typu Mikrotik, np. z serii 951Ui-2HnD albo 751Ui-2HnD, urządzenia te oferują dwa typy pracy: routera i bridge’a – czyli „tryb pomostu”.
    W tej notce rozważymy jednak wariant prostszy w konfiguracji i zrozumieniu, tj. tryb routera.

    UWAGA: wklejenie tak po prostu konfiguracji, którą pokazuję niżej raczej nic nie popsuje, a w niektórych przypadkach konfiguracji domyślnych może nawet zadziałać. Ten wpis nie jest dla tych, którzy szukają prostej recepty na konfigurację. Ale po niewielkich modyfikacjach wszystko powinno zadziałać jak należy.

    Schemat ideowy tej konfiguracji jest pi*oko taki:

      [ router do netu ] 
              \---  [ lanu ] 
                        \--- [ mikrotik z wifi jako router ] 
                                     \--- ( ludzie, dużo ludzi)
    
    

    Minusy takiej konfiguracji to dostęp do wifi dla ludzi – jedno hasło i wlezą wszędzie.
    Możemy to oczywiście ograniczać, np. uruchamiając Mikrotika jako router, uruchamiając na nim NAT i korzystając z dobrodziejstw filtrowania ruchu po IP.

    Ktoś przytomny zauważy, że przecież w ten sposób skomplikujemy sobie setup, bo oprócz odfiltrowania złych, trzeba wpuścić tez dobrych i zaczyna się kombinowanie. A potem zaczyna się bałagan.
    Kolejnym minusem takiego konfiga jest podwójny NAT. Pierwszy na wifi, drugi na wyjściu. Czyli np. żegnajcie VOIPy. Dopuszczalne, ale ogólnie słabe.

    Czyli lepszy schemat byłby taki:

      [ router do netu ]
             \--- [ lan ] --- [ wifi dla gosci ]
                      \--- [ wifi dla pracowników ]
    
    
    

    Ktoś powie – banalne. Kupujemy dwa Mikrotiki, jeden konfigurujemy w trybie pomostu, zakładamy mocne hasło albo podpinamy do serwera Radiusa i wpuszczamy pracowników. Potem kupujemy drugiego, stawiamy go w trybie routera i filtrujemy we wszystkich kierunkach. Skuteczne, ale cóż za przerażające marnowanie zasobów ;-).
    Lepiej pokazać kto wymiata i zrobić to na jednym urządzeniu.

    Czyli będziemy realizować będziemy następujący scenariusz:

    1. stworzymy dwa interfejsy typu VirtualAP – nie będziemy używać interfejsu głównego (wlan1)
    2. stworzymy dwa interfejsy typu bridge – nazwiemy je bridge-local i bridge-remote
    3. dodamy serwer dhcp – żeby goście dostali adresację
    4. dodamy nat – żeby goście wyszli w świat. Raczej nie będą korzystali z VOIPów, więć podwójny nat raczej im nie zaszkodzi.
    5. nałożymy filtry, żeby goście nie rozleźli się po naszym lanie.


    Nie użyjemy głównego interfejsu wifi (wlan1), ponieważ potrzebujemy dwie sieci wifi, które nie będą we wspólnym lanie. Gdybyśmy próbowali ten sam konfig zrobić na głównym i podrzędnym interfejsie wifi, RSTP natychmiast uzna naszą konfigurację za pętlę w sieci i rozłączy drugi interfejs radiowy. A na dwóch podrzędnych interfejsach już się taka sztuka uda.

    Krok 1. tworzymy dwa ifejsy typu VirtualAp (oraz security-profile do nich, czyli osobna, hasła, osobne ssidy, itp).

    Profile nazywają się „guest-wlan” i „firma-wlan” żeby się potem nie pogubić w tej dość zawiłej konfiguracji. Hasła to odpowiednio: DlaObcych i DlaZiemian.

    /interface wireless security-profiles
    add authentication-types=wpa-psk,wpa2-psk management-protection=allowed mode=dynamic-keys name=guest-wlan supplicant-identity=MikroTik wpa-pre-shared-key=DlaObcych wpa2-pre-shared-key=DlaObcych
    add authentication-types=wpa-psk,wpa2-psk management-protection=allowed mode=dynamic-keys name=firma-wlan supplicant-identity=MikroTik wpa-pre-shared-key=DlaZiemian wpa2-pre-shared-key=DlaZiemian

    potem czyścimy główny interfejs wlan1 z SSIDa:
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-ht-above country=russia disabled=no distance=indoors frequency=2462 ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge ssid="" wireless-protocol=802.11

    i dodajemy dwa nowe, slave’y:

    /interface wireless
    add disabled=no l2mtu=2290 mac-address=D6:CA:6D:A8:0C:7C master-interface=wlan1 name=firma-virtual-ap security-profile=firma-wlan ssid=wifi-firmowa wds-default-bridge=bridge-local
    add disabled=no l2mtu=2290 mac-address=D6:CA:6D:A8:0C:7B master-interface=wlan1 name=guest-virtual-ap security-profile=guest-wlan ssid=wifi-guest wds-default-bridge=bridge-local

    Krok 2.tworzymy dwa bridge, -local i -remote, które później wykorzystamy go magii sieciowej:

    /interface bridge
    add admin-mac=D4:CA:6D:A8:0C:77 auto-mac=no name=bridge-local protocol-mode=rstp
    add l2mtu=1598 name=bridge-remote
    /interface bridge port
    add bridge=bridge-local interface=ether2-master-local
    add bridge=bridge-local interface=guest-virtual-ap
    add bridge=bridge-remote interface=ether1-gateway
    add bridge=bridge-remote interface=firma-virtual-ap

    do bridge-local dodaję także lokalne ethernety. Urządzenia z serii (7,9)51 mają kilka portów ethernetowych do wykorzystania.
    Natomiast cała magia jest w pogrubionych linijkach – tutaj dodajemy firmową sieć wifi do bridga do naszego lanu firmowego. A ponieważ to urządzenie w L2 – przeniesie nam dhcp. A ruch wychodzący zamaskaraduje nam NAT na bridge-remote, który nałożymy w kroku 4.

    Krok 3. dodamy serwer DHCP.

    Dodamy go dla gości, i tylko dla gości. DHCP w naszej sieci firmowej (mamy je prawda?) zapewnia inny serwer, tj. albo nasz router, albo nasz serwer AD, albo nasz inny serwer zapewniający DHCP.

    /ip dhcp-server
    add address-pool=default-dhcp disabled=no interface=bridge-local name=guest-server
    /ip dhcp-server network
    add address=192.168.88.0/24 comment="default configuration" dns-server=192.168.88.1 gateway=192.168.88.1

    nie byłem tutaj oryginalny – po prostu użyłem domyślnej konfiguracji.

    Żeby wszytko działało, musimy jeszcze dodać adresację do interfejsu.

    do głównego (teraz to bridge-remote, który spina ether1-gateway i wlan firmowy) – można włączyć dhcp, albo po prostu ustawić statycznie (w tym drugim przypadku należy pamiętać o dodaniu default route) oraz adresacji dla slave (dałem spójne z poprzednimi konfigami)

    /ip address
    add address=192.168.88.1/24 comment="default configuration" interface=bridge-local network=192.168.88.0

    Krok 4. skoro mamy dhcp i interfejsy i wlany – dodajemy nat

    /ip firewall nat
    add action=masquerade chain=srcnat comment="default configuration" out-interface=bridge-remote to-addresses=0.0.0.0 src-address=192.168.88.0/24
    </pre>

    Ale dlaczego bridge-remote a nie ether1-gateway? Ano dlatego, że adresację, oraz nat konfigurujemy na bridgu, a nie na interfejsach podrzędnych.

    Krok 5. a na koniec – odfiltrowujemy element niepożądany:

    (jeżeli oczywiście nasza sieć firmowa ma adresacje 192.168.1.0/24)

    /ip firewall filter
    add action=drop chain=forward dst-address=192.168.1.0/24 src-address=192.168.88.0/24

    A w kolejnym odcinku pokażę, jak to zrobić w druga stronę, tj. jeżeli MT jest w trybie bridge’a. To jest bardziej skomplikowane i zamotane i służy tylko do utrwalenia własnej manii wielkości ;-).


  3. OpenVPN, Mikrotik i Bad LZO decompression header byte

    Marzec 25, 2013 by 0verlord

    mikrotik

    Mikrotik to ogólnie fajny sprzęt i sporo może. Niestety kilka rzeczy jest nie do końca zaimplementowanych. Jedną z tych rzeczy jest OpenVPN.

    Mimo najnowszej wersji softu i na wydawałoby się – poprawnego konfiga, tym razem nie chciał się połączyć.
    Objawy były takie, że łączyło mnie, a po jakimś czasie do loga szedł komunikat
    Inactivity timeout (--ping-restart)
    i oczywiście rozłączało, potem łączyło znowu, znowu nie mogłem nic pingnąć po drugiej stronie i tak w kółko.

    Logi śmiecił jeszcze komunikat pt:
    Bad LZO decompression header byte: (numerek)

    To już w ogóle było pozornie bez związku, ale poszedłem tropem tegoż węża. Po stronie klienta próbowałem to wyłączyć ustawiając
    use-compression=no

    w /ppp profile, ale to nic nie dało. Rzut oka do konfiga po stronie serwera ujawnił straszliwa prawdę – była tam odkomentowana dyrektywa comp-lzo.
    Zakoment, restart openvpna i tadam.wav.

    Podsumowując:

    1. mikrotik obsługuje OpenVPNa w trybie klienta, ale tylko po TCP, udp nie jest zaimplementowane.
    2. … za to obsługuje autoryzację zarówno po certyfikacie, jak i po userze/haśle.
    3. klient nie rozumie kompresji – po stronie serwera trzeba wyłaczyć comp-lzo
    4. jeżeli nie mamy kontroli nad serwerem, i nie możemy tam dodać trasy do podsieci zza naszego vpna, trzeba dodać regułkę maskarady na interfejsie ovpn-out1 (czy też jakkolwiek się u Was nazywa)


  4. LogicMail, IMAP, BlackBerry 9900 Bold, PlusGSM – nie łączy się z serwerwem

    Październik 16, 2012 by 0verlord

    BlackBerry to taka alternatywa dla innych wiodących producentów telefonów. Pominę recenzje, jakoś mi nie pasuje. Ale w Firmie niektórzy sobie wywalczyli. Jak sobie wywalczyli – tak do do nas trafiło do konfiguracji serwerów poczty.

    Polityka bezpieczeństwa w firmie mówi prosto – poczta przechodzi przez serwery firmowe i nie przechodzi przez żadne inne. Więc domyślny tryb BB odpada. Zostało szukać alternatyw i padło na alternatywę tj. program LogicMail. Tutaj ich witryna.

    Początkowa szybka konfiguracja pozwoliła dodać skrzynkę, połączenie z WIFI pozwoliło rzeczone maile poczytać. Na 2G/3G (i ogólnie, internety z komórki) – nie bangla.
    Szybki rzut oka do przeglądarki – net jednak jest, strony się otwierają. Hm. 😐

    Czyli – na WIFI działa, wysyła, odbiera, synchronizuje, itp. Na 3G – nawet się nie łączy, a komunikat z debugu połączenia mówi: „unknown error”, albo „unable to open connection”.

    Pierwsze podejście było dość radosne, okazało się, że na tym konkretnym numerze nie jest włączona transmisja danych. #fail, było sprawdzić wcześniej. Ale w końcu włączyliśmy transmisję.

    Następnego dnia po aktywacji usługi, jest to samo – Unknown error. Po bliższym rzucie oka wyszło, że to dlatego, że nie został ustawiony APN na właściwy dla PLUSa. Właściwie, to w ogóle nie został ustawiony. Więc internet i przeglądarka działała tylko na defaultowych ustawieniach netu w BB. Mylące.

    Ustawia się to dość prosto:

    opcje -> urządzenie -> zaawansowane ustawienia systemu -> tcp ip -> zaznaczamy Ustawienia APN włączone, wybieramy nazwę APNa (właściwe dla odpowiedniej sieci – Plus ma „internet” bez usera ani hasła). Wychodzimy, zapisujemy, klikamy w Logicmaila i tadam.wav.

    (obrazek tytułowy gdzieś z internetu).


  5. [UPDATED do Debiana Wheezy] Hetzner, instalacja Debiana, partycja bios_grub, LVM i RAID

    Wrzesień 27, 2012 by 0verlord

    UPDATE: debian wheezy wymaga trochę więcej miejsca na partycji /boot niż 200M – inaczej image nie bardzo chce się wypakować. Dałem 512M i poszło.
    Czyli:
    PART /boot reiserfs 512M

    (oczywiście filesystem wg własnych upodobań)

    Automatyczny instalator Debiana w Hetznerze pozwala stworzyć w zasadzie dowolną konfigurację partycji pod system. Pomijając te oczywiste konfiguracje z kilkoma partycjami na krzyż, można także wykonać dowolnie skomplikowany zestaw. Np. LVM na SOFT RAIDzie 1 czy też dodanie partycji typu bios_grub.
    Być może moje odkrycia są opisane w hetznerowym wiki, ale nie dałem rady przez nie przebrnąć. Jest zrobione za bardzo „po niemiecku”.

    W każdym razie, należy zacząć od klikania w panel https://robot.your-server.de i wybrania opcji „rescue system”. Potem tylko zapisać wygenerowane hasło i kliknąć w zakładkę „reset”.

    Po zalogowaniu się na system reanimacyjny, wydajemy mroczne polecenie
    installimage

    Uruchamia się instalator w trybie interaktywnym, od razu wrzucając nas do jedynej potrzebnej i sensownej opcji – partycjonera dysku.

    Moje założenie było takie: stworzyć 3 partycje: 1. bios_grub, 2. /boot i macierz RAID 1 pod LVMa.

    NA LVMie miały być partycje wg schematu:

    1. / (root), 20GB
    2. swap, 2x ram
    3. /tmp, 10GB
    4. /var, 20GB
    5. /home reszta

    Jak to teraz poustawiać? Ano tak:

    opcje obowiązkowe w pliku to:

    SWRAID 1
    SWRAIDLEVEL 1

    Pierwsza włącza raid, druga włącza go w trybie mirror. Jeżeli ktoś chce inaczej, można też wybrać stripping (0).

    można też ustawić HOSTNAME.

    Potem konfiguracja partycji, wg schematu:

    PART mountpoint/lvm filesystem/VG rozmiar

    A potem już konfiguracja właściwa:

    #PART /plumk reiserfs 100M
    PART /boot reiserfs 200M
    PART lvm wolumen all

    Dlaczego tak? Ano dlatego, że instalator po stworzeniu partycji, próbuje je wszystkie zamontować, ignorując podstępnie dyrektywy punktu montowania ustawione na „none” (które przechodzi kontrolę składni). Potem partycję odmontujemy, zmienimy jej typ i wszystko będzie dobrze.

    UPDATE: hm hetzner okazał się mądrzejszy, i sam taką partycję zakłada, bez ingerencji usera. Więc można spokojnie olać dodawanie tej partycji na własną rękę. Czyli ostatecznie z wpisu powyżej trzeba uwalić dodawanie dodatkowej partycji z mountpointem /blah.

    W takiej konfiguracji musimy nazwać niżej nasz VG „wolumen”.

    LV wolumen root / reiserfs 20G
    LV wolumen swap swap swap 8G
    LV wolumen tmp /tmp reiserfs 10G
    LV wolumen var /var reiserfs 20G
    LV wolumen home /home reiserfs all

    F10, yes i instalator sobie walczy, a potem robi jak chcemy. 🙂

    Jak mi się wydaje, instalator jest oparty na czymś takim jak Fully Automated Debian Install, kiedyś z niego dość mocno korzystałem, polecam.


  6. Samsung 4GE LTE GT-B3800 – mobilny hotspot od Plusa [aktualizacja: 10-01-2012]

    Maj 15, 2012 by 0verlord

    UPDATE: widać trafiliśmy na jakąś kulawą partię – od miesiąca mamy w firmie 10 takich modemów i tylko jeden sfixował na tyle, że trzeba mu było zrobić reset do ustawień domyślnych. Ludzie narzekają na przegrzewanie się pudełka i nie zawsze zasięg jak na innych modemach. Ale jak jest LTE, to działa jak trzeba.

    UWAGA: zostawiam ten opis jako historyczny, natomiast proszę zacząć czytania od samego dołu, komentarze + ostatnia aktualizacja ujawnia krwawą prawdę, niestety.

    Urządzenie jest całkiem zacne – robi za mini hotspot GSMowy, pozwalając podłączyć do pięciu urządzeń na raz. Oferuje coś takiego Plus, czy inni też – nie wiem.

    Pierwsze wrażenie jest całkiem zacne. Ładne, małe, zasilanie ma z mikrousb, więc od biedy można doładować z komputera w przypadku braku sieci (ładowarkę sieciową też dodali). Bateria ma 1500 mAh, więc teoretycznie powinno jej wystarczyć wg producenta na 216 minut działania – ale stawiam czas zależny od liczby podłączonych urządzeń.

    W środku jest mini router, ma dhcp, ma przekierowanie portów i proste filtrowanie sieci bezprzewodowej po macu. Można też wyłaczyć zabezpieczenia, jeżeli chcemy się podzielić naszym linkiem z najbliższym (i tym dalszym też) otoczeniem.

    Z minusów – nie udało mi się we Wrocławiu złapać jak na razie LTE, podobno nadajników jest niewiele (wg pana konsultanta z salonu – wszystkie 3).

    Urządzenie ma też wyraźnie zauważalny i irytujacy czas łapania sygnału. Kilka razy zdarzyło mi się tak, że musiałem się zalogować do interfejsu i kliknąć wielki czerwony przycisk „connect”. Kto wie, może jak bym wyłaczyć LTE i zostawił tylko 3g/2g to byłoby szybciej, ale nie chciało mi się sprawdzać. W końcu miała być moc LTE, 3g to ja mam ziomy, w telefonie ;-).

    Tak czy siak – urządzenie jest całkiem zacne i umożliwia zestawienie chwilowego punktu w netem tam, gdzie jest to potrzebne nie tylko nam. Oczywiście, malkontenci od razu powiedzą, że ma to iPhone, i pewnie nie tylko on.
    Oczywiście jest to teoria słuszna, jeżeli nie trzeba np. z takiego mobilnego hotspota telefonicznego np. zadzwonić.

    No i wygląda całkiem ładnie, mały, lekki i estetyczny i prosty w obsłudze. Mogę polecić.
    Ale za obiecywanie LTE plus ma u mnie minus. Wielki.

    update z 19-06-2012:

    dzisiaj do mnie wrócił modem od usera z wielkim *rwa mać. Podsumowując usterki i jęczenie usera:

    • przez około 10 dni nie było z nim problemów, następnie się zaczęły,
    • zrywało połączenia,
    • nie łączyło się,
    • wieszało się
    • na koniec przestał nawet świecić lampką.

    W związku z powyższym moją poprzednią pozytywną opinię uznaję za pozbawioną solidnej podstawy, a komentarza za jak najbardziej uzasadnione. Co za złom.


  7. Canon ir 2270 i skanowanie na email

    Kwiecień 5, 2012 by 0verlord

    Skanowanie na email w tej maszynie ustawia się dość prosto, jednak należy pamiętać o jednym detalu, który spowoduje, że mimo poprawnych ustawień – nic, zupełnie nic nie zostanie wysłane na maila. Chodzi tutaj konkretnie o opcję Domain Name :, którą ustawia się w ustawieniach sieci/ dns.
    Dokładniej, klikamy w „Add func.” a następnie w „custom settings” z menu po prawej:

    Potem wybieramy z prawej kolumny opcję DNS server settings, jak na obrazku:

    A tam już wybieramy opcję:

    Domain name:

    i wpisujemy dowolną resolwującą się domenę. Potem trzeba tylko skonfigurować ustawienia wysyłanie emaila, ale to już wg manuala, ja tylko rozwiązuję problemy nierozwiązywalne 😉


  8. Router ADSL SLI 5300 z Netii i hackowanie hasła admina

    Marzec 1, 2012 by 0verlord

    Ten jakże zacny router rozdawała kiedyś Netia w zestawie z telefonem i internetem i „swoim” firmwarem. Router domyślnie ma dwa poziomy dostępu – user (hasło na naklejce z tyłu, lub l/p user/user) i ściśle tajny, admin z niejawnym hasłem. Ale już niedługo niejawny 🙂

    Router ogólnie jest zacny (ma np. funkcjonalność bramki VOIP i całkiem sensowny QOS), ale ma też kilka wad. Domyślnie nie da się zmienić hasła administratora (user admin). „Zablokowano” tą możliwość zwykłemu użytkownikowi. To oznacza, że np. nie możemy wyłączyć serwera dhcp ani ustawiać np. tras statycznych (i jeszcze kilku innych pomniejszych rzeczy).
    Metody na dobranie się do admina ogólnie są dwie. Pierwsza jest gdzieś na forach elektroda.pl. Metoda dość ciekawa, bo także wykorzystująca obejście zabezpieczeń. Konto usera pozwala na zrobienie backupu, z którego wyjmuje się zakodowany dość mizernym szyfrem hasło admina i dekoduje na podstawie załączonego arkusza. Metoda skuteczna, ale mało efektywna. Do admina się dobierzemy, ale w dalszym ciągu nie zmienimy mu hasła. Nasza metoda jest jednak lepsza 🙂

    Ta opowieść jest też z cyklu, dlaczego wszystkie aplikacje web powinny filtrować dane wejściowe i wyjściowe po stronie serwera, a nie Javascriptem po stronie klienta. Dlaczego? Filtrowanie JSem można wyłączyć korzystając z Firebuga. Tak to właśnie zrobiliśmy. Jak się okazało, brak możliwości zmiany hasła admina był „pilnowany” przy pomocy Javascriptu. A więc – firebug, odnalezienie odpowiedniego JSu, ustawienie breakpointa, „hack” i zmiana hasła admina bez ograniczeń i limitów.

    Niech no żyje ten, kto wymyślił takie kozackie zabezpieczenie! Niech żyje! I niech się trzyma z daleka od bezpieczeństwa banku, w którym mam konto :->

    Filmik poniżej. Włączcie fullscreen, będzie cokolwiek widać.

    [swfobj src=”http://rst.evilpackets.org/wp-content/uploads/2012/03/sli5300_admin_hacking1.swf” align=”center” allowfullscreen=”true”]SLI 5300 hack hack[/swfobj]


  9. Innbox v50 modem czy router w Dialogu

    Styczeń 20, 2012 by 0verlord

    Jest sobie takie urządzenie, maszyna piekielna, gra śpiewa i tańczy. Voipy, wideo, telefon, 3play pełną gębą.
    Ale potrzebowałem z niego tylko jednej funkcji, tj modemu do DSLa. Po zgadnięciu z internetu hasła do admina (jest tu) zastrzeliły mnie te wszystkie opcje. Potrzebowałem kawalerii 😉

    Telefon do pomocy technicznej pozwolił przełączyć router w tryb tylko modemu. JTZ? W sumie prosto.
    Trzeba przycisnąć na bocznym panelu przycisk reset. Raz, krótko, bo jak się go przytrzyma więcej niż 10 sekund, pojawią się trzy pomarańczowe lampki i modem zażyczy sobie upgrade softu. Tego oczywiście nie chcemy robić.

    To jednak nie była pełna informacja, ponieważ kabel do internetu należy włożyć do portu nr 1. Na innych portach nie będzie działało.
    Czyli podsumowując: przyciskamy raz przycisk, skrętkę wkładamy do portu nr 1 i zestawiamy przez niego sesję PPPoE. Amen.

    Uprzejmie dziękuję pani z pomocy technicznej za naprowadzenie mnie na odpowiednie rozwiązanie.


  10. regulowanie przepustowości portu na switchu DES-3526

    Grudzień 6, 2011 by 0verlord

    Sprawa jest banalnie prosta, po zalogowaniu się na konto administracyjne i wybraniu portu ofiary, należy wykonać następujące polecenie:
    config bandwidth_control 20 rx_rate 20 tx_rate 20
    save

    tx i rx_rate są podawane w megabitach, więc powyższe polecenie tnie port do 20/20 megabitów.
    Prosto i szybko a i dokładność zadowalająca w sumie do przycinania większych segmentów. Przynajmniej tyle w tym ogólnie dość topornym pudełku. Ale sprawiedliwości trzeba przyznać, odkąd go sklikałem i wstawiłem, ani razu nie wygenerował dziwnego problemu.